wx_Date: Page principale

  • Page principale
  • Classes
  • Fichiers

wx_Date Documentation

1.00

via Folder WXDATE
source http://www.ombrebleu.com/wxsrc/src/ftp/
Généré le Mon Jul 24 12:12:55 2006 pour wx_Date par doxygen 1.4.6-NO


wx_Date: Liste des classes

  • Liste des classes
  • Hiérarchie des classes
  • Membres de classe

wx_Date Liste des classes

Liste des classes, structures, unions et interfaces avec une brève description:
wx_Date -----ajout include perso------------------------------------------------------------------
Généré le Fri Aug 4 12:09:10 2006 pour wx_Date par doxygen 1.4.6-NO


wx_Date: Référence de la classe wx_Date

Référence de la classe wx_Date

-----ajout include perso------------------------------------------------------------------ Plus de détails...

#include <wx_Date.h>

Liste de tous les membres

Fonctions membres publiques

wx_Date ()
-----ajout include perso------------------------------------------------------------------
virtual | ~wx_Date ()
wxString | Merr ()
wxString | RdateE ()
wxString | RdateDMJ ()
wxString | RdateA ()
size_t | RdateN (wxString V_date)
wxString | Ryear ()
wxString | Rmonth ()
wxString | Rday ()
void | Udate ()
bool | Setdate (wxString V_date)
bool | SetEdtDMY (wxString V_DMY)
bool | SetEdtYMD (wxString V_YMD)
bool | Ctrldate (wxString V_date)
void | AddDay (unsigned int V_day)
void | AddMonth (unsigned int V_month)
void | AddYear (unsigned int V_year)
int | CompDate (size_t V_datex, size_t V_datey)
wxString | LongDateDMY ()
wxString | LongDateMY ()

Attributs privés

wxDateTime * | now
wxDateTime * | tst
wxDateSpan * | spn
wxString | syear
wxString | smonth
wxString | sday
unsigned int | nyear
unsigned int | nmonth
unsigned int | nday
wxString | Derr

Description détaillée

-----ajout include perso------------------------------------------------------------------

Définition à la ligne 11 du fichier wx_Date.h.

Documentation des contructeurs et destructeur

wx_Date ( )

-----ajout include perso------------------------------------------------------------------

Définition à la ligne 13 du fichier wx_DATE.cpp.

Références now, spn, et tst.

00013                  {
00014                now = new wxDateTime; now->SetToCurrent();
00015                spn = new wxDateSpan();
00016                tst = new wxDateTime; tst->SetToCurrent();
00017              }; //initalisation *date current

~wx_Date ( ) [virtual]

Définition à la ligne 18 du fichier wx_DATE.cpp.

00018 {};

Documentation des fonctions membres

void AddDay ( unsigned int V_day )

Définition à la ligne 126 du fichier wx_DATE.cpp.

Références nday, now, et spn.

00126                                        {
00127
00128 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00129
00130      spn->SetYears(wxAtoi(now->Format("%Y")));
00131      spn->SetMonths(wxAtoi(now->Format("%m")));
00132      nday = wxAtoi(now->Format("%d"));
00133      spn->SetDays(nday + V_day);
00134
00135 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00136
00137 }

void AddMonth ( unsigned int V_month )

Définition à la ligne 140 du fichier wx_DATE.cpp.

Références nmonth, now, et spn.

00140                                            {
00141
00142 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00143
00144      spn->SetYears(wxAtoi(now->Format("%Y")));
00145      spn->SetDays(wxAtoi(now->Format("%d")));
00146      nmonth = wxAtoi(now->Format("%m"));
00147      spn->SetMonths(nmonth + V_month);
00148
00149 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00150
00151 }

void AddYear ( unsigned int V_year )

Définition à la ligne 154 du fichier wx_DATE.cpp.

Références now, nyear, et spn.

00154                                          {
00155
00156 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00157
00158      spn->SetYears(wxAtoi(now->Format("%Y")) );
00159      spn->SetMonths(wxAtoi(now->Format("%m")));
00160      spn->SetDays(wxAtoi(now->Format("%d")));
00161      nyear =  wxAtoi(now->Format("%Y"));
00162      spn->SetMonths(nyear + V_year);
00163
00164 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00165
00166 }

int CompDate | ( | size_t | V_datex,
 |  | size_t | V_datey
 | ) |

Définition à la ligne 170 du fichier wx_DATE.cpp.

00170                                                          {
00171
00172 if (V_datex < V_datey) return -1;
00173 if (V_datex > V_datey) return 1;
00174 if (V_datex == V_datey) return 0;
00175 return 2;
00176 }

bool Ctrldate ( wxString V_date )

Définition à la ligne 104 du fichier wx_DATE.cpp.

Références Derr, nday, nmonth, nyear, et tst.

00104                                       {
00105
00106 size_t ntest ;
00107 Derr = "";
00108
00109     nyear  = wxAtoi(V_date.SubString(0, 3));
00110     nmonth = wxAtoi(V_date.SubString(4, 5));
00111     nday   = wxAtoi(V_date.SubString(6, 7));
00112  if ( nyear == 0 ) { Derr = " Année " + V_date.SubString(0, 3) + " Invalide ->" + V_date ; return true; }
00113  if ( nmonth == 0 || nmonth > 12 ) {Derr = " Mois  " + V_date.SubString(4, 5) + " Invalide ->" +V_date; return true;}
00114  if ( nday == 0 || nday > 31 ) {Derr = " Jour  " + V_date.SubString(6, 7) + "  Invalide ->" + V_date; return true;}
00115
00116
00117 tst->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ "01"));
00118 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00119 // recherche si jour invalide exemple fevrier
00120 if ( nday > ntest ) { Derr = " Jour  " + V_date.SubString(6, 7) + "  Invalide ->" + V_date; return true;}
00121      return false;
00122 }

wxString LongDateDMY ( )

Définition à la ligne 178 du fichier wx_DATE.cpp.

Références nmonth, now, sday, smonth, et syear.

00178                              {
00179      syear = now->Format("%Y");
00180      nmonth = wxAtoi(now->Format("%m"));
00181     switch(nmonth)
00182    {
00183        case 1 : smonth = "Janvier"; break;
00184        case 2 : smonth = "Février"; break;
00185        case 3 : smonth = "Mars";break;
00186        case 4 : smonth = "Avril";break;
00187        case 5 : smonth = "Mai";break;
00188        case 6 : smonth = "Juin";break;
00189        case 7 : smonth = "Juillet";break;
00190        case 8 : smonth = "Août";break;
00191        case 9 : smonth = "Septembre";break;
00192        case 10 : smonth = "Octobre";break;
00193        case 11 : smonth = "Novembre";break;
00194        case 12 : smonth = "Décembre";break;
00195    }
00196
00197   sday = now->GetWeekDayName(now->GetWeekDay(),Name_Abbr );
00198  if ( sday.Contains("Mon") == true) sday = "Lundi" ;
00199  if ( sday.Contains("Tue") == true) sday = "Mardi" ;
00200  if ( sday.Contains("Wed") == true) sday = "Mercredi" ;
00201  if ( sday.Contains("Thu") == true) sday = "Jeudi" ;
00202  if ( sday.Contains("Fri") == true) sday = "Vendredi" ;
00203  if ( sday.Contains("Sat") == true) sday = "Samedi" ;
00204  if ( sday.Contains("Sun") == true) sday = "Dimanche" ;
00205   return    sday + " " + now->Format("%d") + " " + smonth + " " + syear;;
00206 }

wxString LongDateMY ( )

Définition à la ligne 208 du fichier wx_DATE.cpp.

Références nmonth, now, smonth, et syear.

00208                             {
00209      syear = now->Format("%Y");
00210      nmonth = wxAtoi(now->Format("%m"));
00211     switch(nmonth)
00212    {
00213        case 1 : smonth = "Janvier";break;
00214        case 2 : smonth = "Février";break;
00215        case 3 : smonth = "Mars";break;
00216        case 4 : smonth = "Avril";break;
00217        case 5 : smonth = "Mai";break;
00218        case 6 : smonth = "Juin";break;
00219        case 7 : smonth = "Juillet";break;
00220        case 8 : smonth = "Août";break;
00221        case 9 : smonth = "Septembre";break;
00222        case 10 : smonth = "Octobre";break;
00223        case 11 : smonth = "Novembre";break;
00224        case 12 : smonth = "Décembre";break;
00225    }
00226
00227   return     smonth + " " + syear;;
00228 }

wxString Merr ( )

Définition à la ligne 22 du fichier wx_DATE.cpp.

Références Derr.

00022 {return Derr;}

wxString RdateA ( )

Définition à la ligne 28 du fichier wx_DATE.cpp.

Références now.

00028 {return now->Format("%Y%m%d");}

wxString RdateDMJ ( )

Définition à la ligne 26 du fichier wx_DATE.cpp.

Références now.

00026 {return now->Format("%d/%m/%Y");}

wxString RdateE ( )

Définition à la ligne 24 du fichier wx_DATE.cpp.

Références now.

00024 {return now->Format("%Y/%m/%d");}

size_t RdateN ( wxString V_date )

Définition à la ligne 30 du fichier wx_DATE.cpp.

00030 {return  wxAtoi(V_date.SubString(0, 7));}

wxString Rday ( )

Définition à la ligne 36 du fichier wx_DATE.cpp.

Références now.

00036 {return now->Format("%d");}

wxString Rmonth ( )

Définition à la ligne 34 du fichier wx_DATE.cpp.

Références now.

00034 { return now->Format("%m");}

wxString Ryear ( )

Définition à la ligne 32 du fichier wx_DATE.cpp.

Références now.

00032 {return now->Format("%Y");}

bool Setdate ( wxString V_date )

Définition à la ligne 41 du fichier wx_DATE.cpp.

Références nday, nmonth, now, nyear, et tst.

00041                                      {
00042
00043 size_t ntest ;
00044
00045
00046     nyear  = wxAtoi(V_date.SubString(0, 3));
00047     nmonth = wxAtoi(V_date.SubString(4, 5));
00048     nday   = wxAtoi(V_date.SubString(6, 7));
00049
00050  if ( nyear < 2000 ) return true;
00051  if ( nmonth == 0 || nmonth > 12 ) return true;
00052  if ( nday == 0 || nday > 31 ) return true;
00053
00054
00055 tst->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ "01"));
00056 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00057 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00058 now->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ V_date.SubString(6, 7)));
00059      return false;
00060 }

bool SetEdtDMY ( wxString V_DMY )

Définition à la ligne 62 du fichier wx_DATE.cpp.

Références nday, nmonth, now, nyear, et tst.

00062                                       {
00063
00064 size_t ntest ;
00065
00066
00067     nyear  = wxAtoi(V_DMY.SubString(6, 9));
00068     nmonth = wxAtoi(V_DMY.SubString(3, 4));
00069     nday   = wxAtoi(V_DMY.SubString(0, 1));
00070
00071  if ( nyear < 2000 ) return true;
00072  if ( nmonth == 0 || nmonth > 12 ) return true;
00073  if ( nday == 0 || nday > 31 ) return true;
00074
00075
00076 tst->ParseDate( wxT(V_DMY.SubString(6, 9)+"/"+V_DMY.SubString(3, 4)+"/"+ "01"));
00077 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00078 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00079 now->ParseDate( wxT(V_DMY.SubString(6, 9)+"/"+V_DMY.SubString(3, 4)+"/"+ V_DMY.SubString(0, 1)));
00080      return false;
00081 }

bool SetEdtYMD ( wxString V_YMD )

Définition à la ligne 83 du fichier wx_DATE.cpp.

Références nday, nmonth, now, nyear, et tst.

00083                                       {
00084
00085 size_t ntest ;
00086
00087
00088     nyear  = wxAtoi(V_YMD.SubString(0, 3));
00089     nmonth = wxAtoi(V_YMD.SubString(5, 6));
00090     nday   = wxAtoi(V_YMD.SubString(8, 9));
00091
00092  if ( nyear < 2000 ) return true;
00093  if ( nmonth == 0 || nmonth > 12 ) return true;
00094  if ( nday == 0 || nday > 31 ) return true;
00095
00096
00097 tst->ParseDate( wxT(V_YMD.SubString(0, 3)+"/"+V_YMD.SubString(5, 6)+"/"+ "01"));
00098 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00099 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00100 now->ParseDate( wxT(V_YMD.SubString(0, 3)+"/"+V_YMD.SubString(5, 6)+"/"+ V_YMD.SubString(8, 9)));
00101      return false;
00102 }

void Udate ( )

Définition à la ligne 38 du fichier wx_DATE.cpp.

Références now.

00038 { now->SetToCurrent(); }

Documentation des données membres

wxString Derr [private]

Définition à la ligne 27 du fichier wx_Date.h.

Référencé par Ctrldate(), et Merr().

unsigned int nday [private]

Définition à la ligne 26 du fichier wx_Date.h.

Référencé par AddDay(), Ctrldate(), Setdate(), SetEdtDMY(), et SetEdtYMD().

unsigned int nmonth [private]

Définition à la ligne 25 du fichier wx_Date.h.

Référencé par AddMonth(), Ctrldate(), LongDateDMY(), LongDateMY(), Setdate(), SetEdtDMY(), et SetEdtYMD().

wxDateTime* now [private]

Définition à la ligne 18 du fichier wx_Date.h.

Référencé par AddDay(), AddMonth(), AddYear(), LongDateDMY(), LongDateMY(), RdateA(), RdateDMJ(), RdateE(), Rday(), Rmonth(), Ryear(), Setdate(), SetEdtDMY(), SetEdtYMD(), Udate(), et wx_Date().

unsigned int nyear [private]

Définition à la ligne 24 du fichier wx_Date.h.

Référencé par AddYear(), Ctrldate(), Setdate(), SetEdtDMY(), et SetEdtYMD().

wxString sday [private]

Définition à la ligne 23 du fichier wx_Date.h.

Référencé par LongDateDMY().

wxString smonth [private]

Définition à la ligne 22 du fichier wx_Date.h.

Référencé par LongDateDMY(), et LongDateMY().

wxDateSpan* spn [private]

Définition à la ligne 20 du fichier wx_Date.h.

Référencé par AddDay(), AddMonth(), AddYear(), et wx_Date().

wxString syear [private]

Définition à la ligne 21 du fichier wx_Date.h.

Référencé par LongDateDMY(), et LongDateMY().

wxDateTime* tst [private]

Définition à la ligne 19 du fichier wx_Date.h.

Référencé par Ctrldate(), Setdate(), SetEdtDMY(), SetEdtYMD(), et wx_Date().

La documentation de cette classe a été générée à partir des fichiers suivants:
  • C:/Dev-Cpp/include/wx/wxDate/wx_Date.h
  • C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp


wx_Date: Liste des membres

wx_Date Liste des membres

Liste complète des membres de wx_Date, y compris les membres hérités:

AddDay(unsigned int V_day) | wx_Date |
AddMonth(unsigned int V_month) | wx_Date |
AddYear(unsigned int V_year) | wx_Date |
CompDate(size_t V_datex, size_t V_datey) | wx_Date |
Ctrldate(wxString V_date) | wx_Date |
Derr | wx_Date | [private]
LongDateDMY() | wx_Date |
LongDateMY() | wx_Date |
Merr() | wx_Date |
nday | wx_Date | [private]
nmonth | wx_Date | [private]
now | wx_Date | [private]
nyear | wx_Date | [private]
RdateA() | wx_Date |
RdateDMJ() | wx_Date |
RdateE() | wx_Date |
RdateN(wxString V_date) | wx_Date |
Rday() | wx_Date |
Rmonth() | wx_Date |
Ryear() | wx_Date |
sday | wx_Date | [private]
Setdate(wxString V_date) | wx_Date |
SetEdtDMY(wxString V_DMY) | wx_Date |
SetEdtYMD(wxString V_YMD) | wx_Date |
smonth | wx_Date | [private]
spn | wx_Date | [private]
syear | wx_Date | [private]
tst | wx_Date | [private]
Udate() | wx_Date |
wx_Date() | wx_Date |
~wx_Date() | wx_Date | [virtual]


wx_Date: Index des fichiers

wx_Date Liste des fichiers

Liste de tous les fichiers avec une brève description:
C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp [code]
C:/Dev-Cpp/include/wx/wxDate/wx_Date.h [code]


wx_Date: Membres de classe

  • Tout
  • Fonctions
  • Variables
  • a
  • c
  • d
  • l
  • m
  • n
  • r
  • s
  • t
  • u
  • w
  • ~

Liste de tous les membres de classe avec liens vers les classes auxquelles ils appartiennent:

- a -

  • AddDay() : wx_Date
  • AddMonth() : wx_Date
  • AddYear() : wx_Date

- c -

  • CompDate() : wx_Date
  • Ctrldate() : wx_Date

- d -

  • Derr : wx_Date

- l -

  • LongDateDMY() : wx_Date
  • LongDateMY() : wx_Date

- m -

  • Merr() : wx_Date

- n -

  • nday : wx_Date
  • nmonth : wx_Date
  • now : wx_Date
  • nyear : wx_Date

- r -

  • RdateA() : wx_Date
  • RdateDMJ() : wx_Date
  • RdateE() : wx_Date
  • RdateN() : wx_Date
  • Rday() : wx_Date
  • Rmonth() : wx_Date
  • Ryear() : wx_Date

- s -

  • sday : wx_Date
  • Setdate() : wx_Date
  • SetEdtDMY() : wx_Date
  • SetEdtYMD() : wx_Date
  • smonth : wx_Date
  • spn : wx_Date
  • syear : wx_Date

- t -

  • tst : wx_Date

- u -

  • Udate() : wx_Date

- w -

  • wx_Date() : wx_Date

- ~ -

  • ~wx_Date() : wx_Date


wx_Date: Membres de classe - Fonctions

  • Tout
  • Fonctions
  • Variables

  • AddDay() : wx_Date
  • AddMonth() : wx_Date
  • AddYear() : wx_Date
  • CompDate() : wx_Date
  • Ctrldate() : wx_Date
  • LongDateDMY() : wx_Date
  • LongDateMY() : wx_Date
  • Merr() : wx_Date
  • RdateA() : wx_Date
  • RdateDMJ() : wx_Date
  • RdateE() : wx_Date
  • RdateN() : wx_Date
  • Rday() : wx_Date
  • Rmonth() : wx_Date
  • Ryear() : wx_Date
  • Setdate() : wx_Date
  • SetEdtDMY() : wx_Date
  • SetEdtYMD() : wx_Date
  • Udate() : wx_Date
  • wx_Date() : wx_Date
  • ~wx_Date() : wx_Date


wx_Date: Membres de classe - Variables

  • Tout
  • Fonctions
  • Variables

  • Derr : wx_Date
  • nday : wx_Date
  • nmonth : wx_Date
  • now : wx_Date
  • nyear : wx_Date
  • sday : wx_Date
  • smonth : wx_Date
  • spn : wx_Date
  • syear : wx_Date
  • tst : wx_Date


wx_Date: Index hiérarchique

wx_Date Hiérarchie des classes

Cette liste d'héritage est classée approximativement par ordre alphabétique:
  • wx_Date


wx_Date: Référence du fichier C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp

Référence du fichier C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp

#include "wx/wxDate/wx_date.h"
#include <wx/datetime.h>
#include <wx/string.h>

Aller au code source de ce fichier.


wx_Date: Fichier source de C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp

C:/Dev-Cpp/include/wx/wxDate/wx_DATE.cpp

Aller à la documentation de ce fichier.
00001 #ifndef __PROJETDATE_cpp__
00002 #define __PROJETDATE_cpp__
00003
00004 #include "wx/wxDate/wx_date.h"
00005 #include <wx/datetime.h>
00006 #include <wx/string.h>
00008 // les zone V_Date sont de 8 carateres aaaammjj
00009 // pour les tries la compatibilé DB2 ... SQLITE
00010 // 00000000 etant des critéres de selection et que NULL pose de prblm
00011
00012
00013 wx_Date::wx_Date() {
00014                now = new wxDateTime; now->SetToCurrent();
00015                spn = new wxDateSpan();
00016                tst = new wxDateTime; tst->SetToCurrent();
00017              }; //initalisation *date current
00018  wx_Date::~wx_Date(){};
00019
00020
00021 // Return  wx_Date Message err
00022 wxString wx_Date::Merr() {return Derr;}
00023 // Return  wx_Date Formaté AAAA/MM/JJ edit mask
00024 wxString wx_Date::RdateE() {return now->Format("%Y/%m/%d");}
00025 // Return  wx_Date Formaté jj/MM/AAAA edit mask
00026 wxString wx_Date::RdateDMJ() {return now->Format("%d/%m/%Y");}
00027 // Return  wx_Date Formaté AAAAMMJJ Alpha
00028 wxString wx_Date::RdateA() {return now->Format("%Y%m%d");}
00029 // Return  wx_Date Formaté AAAAMMJJ Numérique
00030 size_t wx_Date::RdateN(wxString V_date) {return  wxAtoi(V_date.SubString(0, 7));}
00031 // Return  wx_Date Formaté AAAA
00032 wxString wx_Date::Ryear() {return now->Format("%Y");}
00033 // Return  wx_Date Formaté MM
00034 wxString wx_Date::Rmonth() { return now->Format("%m");}
00035 // Return  wx_Date Formaté JJ
00036 wxString wx_Date::Rday() {return now->Format("%d");}
00037 // Set Udate   wx_Date
00038 void wx_Date::Udate() { now->SetToCurrent(); }
00039
00040 // Set  wx_Date  YYYYMMJJ
00041 bool wx_Date::Setdate(wxString V_date) {
00042
00043 size_t ntest ;
00044
00045
00046     nyear  = wxAtoi(V_date.SubString(0, 3));
00047     nmonth = wxAtoi(V_date.SubString(4, 5));
00048     nday   = wxAtoi(V_date.SubString(6, 7));
00049
00050  if ( nyear < 2000 ) return true;
00051  if ( nmonth == 0 || nmonth > 12 ) return true;
00052  if ( nday == 0 || nday > 31 ) return true;
00053
00054
00055 tst->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ "01"));
00056 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00057 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00058 now->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ V_date.SubString(6, 7)));
00059      return false;
00060 }
00061 // Set  wx_Date  JJ/MM/AAAA
00062 bool wx_Date::SetEdtDMY(wxString V_DMY) {
00063
00064 size_t ntest ;
00065
00066
00067     nyear  = wxAtoi(V_DMY.SubString(6, 9));
00068     nmonth = wxAtoi(V_DMY.SubString(3, 4));
00069     nday   = wxAtoi(V_DMY.SubString(0, 1));
00070
00071  if ( nyear < 2000 ) return true;
00072  if ( nmonth == 0 || nmonth > 12 ) return true;
00073  if ( nday == 0 || nday > 31 ) return true;
00074
00075
00076 tst->ParseDate( wxT(V_DMY.SubString(6, 9)+"/"+V_DMY.SubString(3, 4)+"/"+ "01"));
00077 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00078 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00079 now->ParseDate( wxT(V_DMY.SubString(6, 9)+"/"+V_DMY.SubString(3, 4)+"/"+ V_DMY.SubString(0, 1)));
00080      return false;
00081 }
00082 // Set  wx_Date  AAAA/MM/JJ
00083 bool wx_Date::SetEdtYMD(wxString V_YMD) {
00084
00085 size_t ntest ;
00086
00087
00088     nyear  = wxAtoi(V_YMD.SubString(0, 3));
00089     nmonth = wxAtoi(V_YMD.SubString(5, 6));
00090     nday   = wxAtoi(V_YMD.SubString(8, 9));
00091
00092  if ( nyear < 2000 ) return true;
00093  if ( nmonth == 0 || nmonth > 12 ) return true;
00094  if ( nday == 0 || nday > 31 ) return true;
00095
00096
00097 tst->ParseDate( wxT(V_YMD.SubString(0, 3)+"/"+V_YMD.SubString(5, 6)+"/"+ "01"));
00098 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00099 if ( nday > ntest ) return true; // recherche si jour invalide exemple fevrier
00100 now->ParseDate( wxT(V_YMD.SubString(0, 3)+"/"+V_YMD.SubString(5, 6)+"/"+ V_YMD.SubString(8, 9)));
00101      return false;
00102 }
00103 // Contôle  wx_Date
00104 bool wx_Date::Ctrldate(wxString V_date) {
00105
00106 size_t ntest ;
00107 Derr = "";
00108
00109     nyear  = wxAtoi(V_date.SubString(0, 3));
00110     nmonth = wxAtoi(V_date.SubString(4, 5));
00111     nday   = wxAtoi(V_date.SubString(6, 7));
00112  if ( nyear == 0 ) { Derr = " Année " + V_date.SubString(0, 3) + " Invalide ->" + V_date ; return true; }
00113  if ( nmonth == 0 || nmonth > 12 ) {Derr = " Mois  " + V_date.SubString(4, 5) + " Invalide ->" +V_date; return true;}
00114  if ( nday == 0 || nday > 31 ) {Derr = " Jour  " + V_date.SubString(6, 7) + "  Invalide ->" + V_date; return true;}
00115
00116
00117 tst->ParseDate( wxT(V_date.SubString(0, 3)+"/"+V_date.SubString(4, 5)+"/"+ "01"));
00118 ntest =     GetNumberOfDays(tst->GetMonth(), tst->GetYear());
00119 // recherche si jour invalide exemple fevrier
00120 if ( nday > ntest ) { Derr = " Jour  " + V_date.SubString(6, 7) + "  Invalide ->" + V_date; return true;}
00121      return false;
00122 }
00123
00124
00125 // ADD Day to  wx_Date
00126 void wx_Date::AddDay(unsigned int V_day) {
00127
00128 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00129
00130      spn->SetYears(wxAtoi(now->Format("%Y")));
00131      spn->SetMonths(wxAtoi(now->Format("%m")));
00132      nday = wxAtoi(now->Format("%d"));
00133      spn->SetDays(nday + V_day);
00134
00135 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00136
00137 }
00138
00139 // ADD Month to  wx_Date
00140 void wx_Date::AddMonth(unsigned int V_month) {
00141
00142 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00143
00144      spn->SetYears(wxAtoi(now->Format("%Y")));
00145      spn->SetDays(wxAtoi(now->Format("%d")));
00146      nmonth = wxAtoi(now->Format("%m"));
00147      spn->SetMonths(nmonth + V_month);
00148
00149 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00150
00151 }
00152
00153 // ADD Year to  wx_Date
00154 void wx_Date::AddYear(unsigned int V_year) {
00155
00156 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00157
00158      spn->SetYears(wxAtoi(now->Format("%Y")) );
00159      spn->SetMonths(wxAtoi(now->Format("%m")));
00160      spn->SetDays(wxAtoi(now->Format("%d")));
00161      nyear =  wxAtoi(now->Format("%Y"));
00162      spn->SetMonths(nyear + V_year);
00163
00164 now->ParseDate( wxString::Format("%d/%02d/%02d",spn->GetYears(),spn->GetMonths(),spn->GetDays()));
00165
00166 }
00167
00168
00169 // Comp date Numerique return 1=*GT 0=EQ -1=*LT
00170 int  wx_Date::CompDate(size_t V_datex ,  size_t V_datey  ) {
00171
00172 if (V_datex < V_datey) return -1;
00173 if (V_datex > V_datey) return 1;
00174 if (V_datex == V_datey) return 0;
00175 return 2;
00176 }
00177
00178 wxString wx_Date::LongDateDMY(){
00179      syear = now->Format("%Y");
00180      nmonth = wxAtoi(now->Format("%m"));
00181     switch(nmonth)
00182    {
00183        case 1 : smonth = "Janvier"; break;
00184        case 2 : smonth = "Février"; break;
00185        case 3 : smonth = "Mars";break;
00186        case 4 : smonth = "Avril";break;
00187        case 5 : smonth = "Mai";break;
00188        case 6 : smonth = "Juin";break;
00189        case 7 : smonth = "Juillet";break;
00190        case 8 : smonth = "Août";break;
00191        case 9 : smonth = "Septembre";break;
00192        case 10 : smonth = "Octobre";break;
00193        case 11 : smonth = "Novembre";break;
00194        case 12 : smonth = "Décembre";break;
00195    }
00196
00197   sday = now->GetWeekDayName(now->GetWeekDay(),Name_Abbr );
00198  if ( sday.Contains("Mon") == true) sday = "Lundi" ;
00199  if ( sday.Contains("Tue") == true) sday = "Mardi" ;
00200  if ( sday.Contains("Wed") == true) sday = "Mercredi" ;
00201  if ( sday.Contains("Thu") == true) sday = "Jeudi" ;
00202  if ( sday.Contains("Fri") == true) sday = "Vendredi" ;
00203  if ( sday.Contains("Sat") == true) sday = "Samedi" ;
00204  if ( sday.Contains("Sun") == true) sday = "Dimanche" ;
00205   return    sday + " " + now->Format("%d") + " " + smonth + " " + syear;;
00206 }
00207
00208 wxString wx_Date::LongDateMY(){
00209      syear = now->Format("%Y");
00210      nmonth = wxAtoi(now->Format("%m"));
00211     switch(nmonth)
00212    {
00213        case 1 : smonth = "Janvier";break;
00214        case 2 : smonth = "Février";break;
00215        case 3 : smonth = "Mars";break;
00216        case 4 : smonth = "Avril";break;
00217        case 5 : smonth = "Mai";break;
00218        case 6 : smonth = "Juin";break;
00219        case 7 : smonth = "Juillet";break;
00220        case 8 : smonth = "Août";break;
00221        case 9 : smonth = "Septembre";break;
00222        case 10 : smonth = "Octobre";break;
00223        case 11 : smonth = "Novembre";break;
00224        case 12 : smonth = "Décembre";break;
00225    }
00226
00227   return     smonth + " " + syear;;
00228 }
00229
00230 #endif
00231
00232 //wx_Date *Pdate= new wx_Date;


wx_Date: Référence du fichier C:/Dev-Cpp/include/wx/wxDate/wx_Date.h

Référence du fichier C:/Dev-Cpp/include/wx/wxDate/wx_Date.h

#include <wx/datetime.h>
#include <wx/string.h>

Aller au code source de ce fichier.

Classes

class wx_Date
-----ajout include perso------------------------------------------------------------------ Plus de détails...


wx_Date: Fichier source de C:/Dev-Cpp/include/wx/wxDate/wx_Date.h

C:/Dev-Cpp/include/wx/wxDate/wx_Date.h

Aller à la documentation de ce fichier.
00001    #ifndef __PROJETDATE_hpp__
00002 #define __PROJETDATE_hpp__
00003
00004 #include <wx/datetime.h>
00005 #include <wx/string.h>
00007 // les zone V_Date sont de 8 carateres aaaammjj
00008 // pour les tries la compatibilé DB2 ... SQLITE
00009 // 00000000 etant des critéres de selection et que NULL pose de prblm
00010
00011 class wx_Date : public wxDateTime
00012 {
00013  public:
00014    wx_Date() ;
00015    virtual ~wx_Date();
00016
00017  private:
00018  wxDateTime *now ;
00019  wxDateTime *tst ;
00020  wxDateSpan *spn ;
00021      wxString syear;
00022      wxString smonth;
00023      wxString sday;
00024      unsigned int nyear;
00025      unsigned int nmonth;
00026      unsigned int nday;
00027      wxString Derr;
00028
00029 public:
00030 // Return  wx_Date Message err
00031 wxString wx_Date::Merr() ;
00032
00033 // Return  wx_Date Formaté AAAA/MM/JJ edit mask
00034 wxString wx_Date::RdateE();
00035
00036 // Return  wx_Date Formaté jj/MM/AAAA edit mask
00037 wxString wx_Date::RdateDMJ();
00038
00039 // Return  wx_Date Formaté AAAAMMJJ Alpha
00040 wxString wx_Date::RdateA();
00041
00042 // Return  wx_Date Formaté AAAAMMJJ Numérique
00043 size_t wx_Date::RdateN(wxString V_date);
00044
00045 // Return  wx_Date Formaté AAAA
00046 wxString wx_Date::Ryear() ;
00047
00048 // Return  wx_Date Formaté MM
00049 wxString wx_Date::Rmonth() ;
00050
00051 // Return  wx_Date Formaté JJ
00052 wxString wx_Date::Rday() ;
00053
00054 // Set Udate   wx_Date
00055 void wx_Date::Udate() ;
00056
00057 // Set  wx_Date  YYYYMMJJ
00058 bool wx_Date::Setdate(wxString V_date) ;
00059
00060 // Set  wx_Date  JJ/MM/AAAA
00061 bool wx_Date::SetEdtDMY(wxString V_DMY) ;
00062
00063 // Set  wx_Date  AAAA/MM/JJ
00064 bool wx_Date::SetEdtYMD(wxString V_YMD) ;
00065
00066 // Contôle  wx_Date
00067 bool wx_Date::Ctrldate(wxString V_date) ;
00068
00069 // ADD Day to  wx_Date
00070 void wx_Date::AddDay(unsigned int V_day) ;
00071
00072 // ADD Month to  wx_Date
00073 void wx_Date::AddMonth(unsigned int V_month) ;
00074
00075 // ADD Year to  wx_Date
00076 void wx_Date::AddYear(unsigned int V_year) ;
00077
00078
00079 // Comp date Numerique return 1=*GT 0=EQ -1=*LT
00080 int  wx_Date::CompDate(size_t V_datex ,  size_t V_datey  ) ;
00081
00082 // Format date Jour nn Mois Année
00083 wxString wx_Date::LongDateDMY();
00084
00085 // Format date  Mois Année
00086 wxString wx_Date::LongDateMY();
00087 };
00088 #endif
00089